A couple questions regarding polycode

  1. 6 months ago
    1. Which version of OpenGL does Polycode use?
    2. Which version of LUA does Polycode use?
    3. Are there any plans to add Vulkan support?
  2. Adding Vulkan support will be cool. The new-gen OpenGL!!! But I feel that currently even if it is not there it will be fine.

  3. Edited 6 months ago by zeebok

    I believe it is using Lua 5.1 as of right now. Not sure if it will be updated in the big rewrite being done.

    As for the OpenGL version, I am not 100% sure. Looking at a couple of the shaders in the default pak it is 2.1

    Vulkan support would be great and am personally interested in looking at how to add it to Polycode after I finish helping with the VR support. It would benefit both this and my job so I just need to find the time.

  4. fodinabor

    27 Sep 2016 Administrator

    We are trying to comply with OpenGL ES 2.0 on most platforms (although desktop platforms use standard OpenGL not ES)

    Goodbye_cmake (the big rewrite mentioned earlier) uses Lua 5.3

    And Vulkan support is not planned - although I guess it would be a nice to have feature :)

 

or Sign Up to reply!